В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
toshakovanadez
toshakovanadez
24.02.2021 19:37 •  Информатика

Напишите программу, которая вводит с клавиатуры 20 реальных чисел, и организовывает их хранение в массиве. после этого определяет сумму элементов, значение которых больше среднего арифметического элементов массива.

Ответ:
Юлька1150989776543
Юлька1150989776543
24.09.2020 11:17
Const n=20;
var x:array[1..n] of real;
i:integer; s,sr:real;
begin
for i:=1 to n do
 begin
 write('x[',i,']=');
 readln(x[i]);
 end;
s:=0;
for i:=1 to n do s:=s+x[i];
sr:=s/n;
s:=0;
for i:=1 to n do
 if x[i]<sr then s:=s+x[i];
writeln('sr = ',sr,'  s = ',s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?