В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

1)дан вектор {zi},i=.составьте программу ввода значений и вычисления длины этого вектора по следующей формуле: l=корень квадратный z1 в кв.+z2 в кв.+ в кв. 2)даны значения массива {ai}, i= и переменной х. составьте программу вычисления многочлена 10-й степени по формуле герона: а10х в 10 степени+а9хв 10 степени++а1х+а0=+а9)х+а8)х++а1)х+а0.

Ответ:
onaleman
onaleman
24.09.2020 10:56

1)

const

   handsfree = false;

   nmax = 50;

   random_min = -50;

   random_max = 50;

var

   a: array[1..nmax] of real;

   i, n: integer;

   sum: real;

begin

   {ввод массива}

   n := nmax;

   if handsfree then begin

       for i := 1 to n do

       begin

           a[i] := random(random_max - random_min) + random_min;

           write(a[i], ' ');

       end

   end

   else begin

       for i := 1 to n do

           readln(a[i]);

   end;

   writeln();

   

   {подсчет суммы}

   sum := 0;

   for i := 1 to n do

       sum := sum + sqr(a[i]);

   writeln('L = ', sqrt(sum));

end.

2)

const

   handsfree = false;

   nmax = 10;

   random_min = -50;

   random_max = 50;

var

   a: array[0..nmax] of real;

   i, n: integer;

   sum, x: real;

begin

   {ввод массива}

   n := nmax;

   if handsfree then begin

       for i := 0 to n do

       begin

           a[i] := random(random_max - random_min) + random_min;

           write(a[i], ' ');

       end

   end

   else begin

       for i := 0 to n do

           readln(a[i]);

   end;

   writeln();

   

   {подсчет суммы}

   write('x = ');

   readln(x);

   

   sum := a[n];

   for i := n - 1 downto 0 do

       sum := sum * x + a[i];

   writeln('S = ', sqrt(sum));

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?