В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Dasha1231232007123
Dasha1231232007123
26.08.2020 13:44 •  Информатика

Напишите программу, которая заменяет в символьной строке все буквы a на буквы b , буквы a на буквы b , буквы b на буквы a и буквы b на буквы a . в c++

Ответ:
Winxsori
Winxsori
07.08.2020 13:31
#include <iostream>
#include <string>
using namespace std;

int main()
{
string st;
cout <<"Введите строку; ";
getline(cin, st);
for(auto it=st.begin(); it!=st.end(); ++it)
{
switch(*it)
{
case 'a': { *it='b'; break; }
case 'b': { *it='a'; break; }
case 'A': { *it='B'; break; }
case 'B': { *it='A'; break; }
}

}
cout <<"Измененная строка: " <<st << endl;

return 0;

}

Результат работы программы на скриншоте.
Напишите программу, которая заменяет в символьной строке все буквы a на буквы b , буквы a на буквы b
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?