Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
shyndari
04.01.2021 13:04 •
Информатика
Написать программу в паскале. дано число n. найти сумму его делителей.
Ответ:
Sawensia
03.10.2020 12:09
Var n,s,i:integer;
begin
write('N = '); readln(n);
if n>1 then s:=1+n else s:=1;
for i:=2 to n div 2 do
if n mod i = 0 then s:=s+i;
writeln('S = ',s);
end.
Пример:
N = 12
S = 28
0,0
(0 оценок)
Популярные вопросы: Информатика
Legendplay228
25.09.2021 22:17
Написать программу, на ассемблере, которая выводит на экран сумму, разность, произведение, частное введённое с клавиатуры...
kalinkamalinka369
02.08.2021 11:40
ответьте на вопросы 1 Почему следующая программа не работает?C=777print(c)2 Почему эта программа не работает?a=10print(a,b)b=20...
Adln48
08.06.2020 13:01
Что такое транссировачная таблица?...
Попова1234
27.10.2020 19:17
Что такое ручная трассировка...
naziflashru
14.07.2020 01:02
По информатике тут из цыфр должно быть 100101011001001010101010100010111011101010101001100101010101 011010010011110100001010101010101010001001010010100100101001001 10101100101010010010100010...
annasefershaeva
17.12.2021 20:47
Какие чувства возникли после прочтения рассказа цифры ?...
solopova08
28.01.2023 23:12
ответ на 1 корова в день съедает 47 кг корма,сколько корма нужно закотовить на год для 1 коровы при одинаковой норма выдачи сена? а для 23 коров нужно уже через 10 минут...
ВикторияТуп
15.09.2020 18:07
Есть ли однокоренное слово к слову убирать с корнем бер? если есть то какое заранее !...
dhjejdj
15.09.2020 18:07
Таблица по биологии: строение и функции кожи! первый столбик: слой кожи второй столбик: строение третий столбик: функции...
1izzka000
02.05.2023 17:22
Составить 8предложений с местоимениями...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
write('N = '); readln(n);
if n>1 then s:=1+n else s:=1;
for i:=2 to n div 2 do
if n mod i = 0 then s:=s+i;
writeln('S = ',s);
end.
Пример:
N = 12
S = 28