В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
LobovM
LobovM
26.10.2020 15:52 •  Информатика

Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел

Ответ:
Амина762
Амина762
24.09.2020 06:48
Не указано сколько раз оно должно принимать значение и каким образом вообще принять. Здесь оно 5 раз примет какие-то числа (каждое с новой строки), а потом выведет кол-во + и -. Значение 0 оно просто пропускает. Если все 5 чисел будут = 0, то и на выходе оно скажет, что было введено 0 значений с + и 0 значений с-.

Код (скриншот прилагается):
var minus, plus, input, i: integer;
begin
minus:= 0;
plus:= 0;
for i:=0 to 4 do
begin
readln(input);
if input > 0 then plus:=plus+1;
else if input < 0 then minus:=minus+1;
end;
writeln(plus, ' positive and ', minus, ' negative numbers.');
end.
Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отр
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?