Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
черныйхащ
18.02.2022 06:07 •
Информатика
)информатика ввод 10 элементов массива случайным образом из диапазона от (-50,50). посчитать кол-во отрицательных чисел. написать программу
Ответ:
scaier
03.10.2020 11:50
// PascalABC.NET 3.1, сборка 1211 от 31.03.2016
begin
var a:=ArrRandom(10,-50,50); a.Println;
Writeln('Отрицательных ',a.Where(x->x<0).Count)
end.
Тестовое решение:
37 -20 2 -13 10 9 -25 11 8 -3
Отрицательных 4
0,0
(0 оценок)
Ответ:
aida04gmailcom
03.10.2020 11:50
Var
a: array[1..10] of integer;
i, n: integer;
begin
for i := 1 to 10 do
begin
a[i] := random(101) - 50;
if a[i] < 0 then n := n + 1;
write(a[i]:4);
end;
writeln;
writeln('Количество отрицательных = ', n);
end.
Тестовое решение
30 1 -23 -36 15 -40 18 38 43 47
Количество отрицательных = 3
0,0
(0 оценок)
Популярные вопросы: Информатика
kamilaraeva
13.07.2022 14:48
Дан текст из пяти предложений вывести на экран четвертое предложение qbasic...
lear8765
28.04.2022 06:25
Дано дерево каталогов. Запишите полные имена (пути) для следующих файлов через запятую: мелодия.mp3, Бия.jpeg, Онегин.doc...
Соря11
11.07.2021 03:41
Решите задачи: 1)Сканируется цветное изображение размером 16 х 16 см. Разрешающая сканера 600 х 600 dpi, глубина цвета — 2 байта. Какой информационный объём будет иметь полученный...
bezzzdarnost
03.01.2022 15:08
До будь ласка Фрагмент алгоритму або алгоритм, особливістю якого є те, що всі його команди обов’язково виконуються, причому кожна тільки по одному разу, називається . а)Наслідковим...
Вишня007
06.10.2021 09:25
Запиши число 13383 в развёрнутом виде, начиная со старшего разряда...
prostonick111237
25.08.2022 05:00
Человек загадал некое целое положительное число n. Определите, возможно ли сделать это число кратным 8, при условии что разрешается изменить порядок цифр в числе. Заметьте, что полученное...
vvbedash
17.10.2021 21:55
питон while или for с клавиатуры запрашиввается любое число от 2 до 9. напечатать на экране таблицу умножения на это число...
Опаснаятётя01
28.01.2020 17:29
питон while или for ввести с клавиатуры количество повторений и вывести столько же раз какое-нибудь сообщение...
pogasii
23.04.2020 12:29
С клавиатуры вводится целое число. Определить, будет ли оно делителем числа 729....
марьяна126
04.04.2022 01:52
Вопрос 1 В таблице приведены запросы к поисковому серверу. Для каждого запроса указан его код — соответствующая буква от А до Г. Расположите коды запросов...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
var a:=ArrRandom(10,-50,50); a.Println;
Writeln('Отрицательных ',a.Where(x->x<0).Count)
end.
Тестовое решение:
37 -20 2 -13 10 9 -25 11 8 -3
Отрицательных 4
a: array[1..10] of integer;
i, n: integer;
begin
for i := 1 to 10 do
begin
a[i] := random(101) - 50;
if a[i] < 0 then n := n + 1;
write(a[i]:4);
end;
writeln;
writeln('Количество отрицательных = ', n);
end.
Тестовое решение
30 1 -23 -36 15 -40 18 38 43 47
Количество отрицательных = 3