В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Superstylegir
Superstylegir
30.03.2023 01:53 •  Информатика

Нужно написать программу, где в матрице будут по порядку числа от 1 до 30

Ответ:
565п
565п
19.08.2020 16:14
Так как в задаче идет речь о матрице, то возможные варианты такой матрицы (исключаем 1х30 и 30х1):
2х15
3х10
5х6
Далее повторения (меняются столбцы и строки)
6х5
10х3
15х2
Попробуем написать программу, которая создает нужную матрицу  по первому числу (количество строк) и заполняет ее:

//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var
  a:array[,] of integer;
  n,m,i,j,k:integer;
begin
  k:=1;
  write('Введите количество строк (одно число из 2,3,5,6,10,15) ');
  readln(n); m:=30 div n;
  a:=new integer[n,m];
  for i:=0 to n-1 do begin
    for j:=0 to m-1 do begin
     a[i,j]:=k; k:=k+1;
     write(a[i,j]:3);
   end;
   writeln;
  end;
end.

Тест №1
Введите количество строк 5
  1  2  3  4  5  6
  7  8  9 10 11 12
 13 14 15 16 17 18
 19 20 21 22 23 24
 25 26 27 28 29 30

Тест №2
Введите количество строк 3
  1  2  3  4  5  6  7  8  9 10
 11 12 13 14 15 16 17 18 19 20
 21 22 23 24 25 26 27 28 29 30
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?