В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
EnderCrash7821
EnderCrash7821
18.08.2021 17:12 •  Информатика

Написать программу,которая выведет все числа кратные 3 в диапазоне от 26 до 87

Ответ:
rasolcheatnet
rasolcheatnet
03.10.2020 11:38
//Pascal ABC.NET v3.1 сборка 1172

begin
range(26,87).Where(x -> x mod 3=0).Println(',');
end.
0,0(0 оценок)
Ответ:
крис897
крис897
03.10.2020 11:38
Решение №1 (через целочисленное деление)

var a: integer;
begin
  a:=26;
  repeat
    if a mod 3 =0 then write(a:3);
    a:=a+1;
  until a >87;
end.

Решение №2 (без целочисленного деления)
Заметим, что первое число в данном диапазоне кратное 3 равно 27. Тогда каждое следуещее число на 3 больше предыдущего:

var a: integer;
begin
  a:=27;
  repeat
    write(a:3);
    a:=a+3;
  until a >87;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?