В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sukhovilopolina
sukhovilopolina
21.11.2022 15:59 •  Информатика

Напишите алгоритм в виде программы на паскале напишите ая алгоритм вычисления у по формуле у=(1-х²+5х^4)², где х- заданное число. учтите следующие ограничения: 1) в арифмитических выражения можно использовать только операции сложения, вычитания и умножения. 2) каждое выражение может содержать только одну арифметическую операцию. выполните трассировку алгоритма при х= 2. добавлю за ответ без

Ответ:
Shavelko
Shavelko
03.10.2020 11:34
Var x,x2,x4,y:real;
begin
write('x = '); readln(x);
x2:=x*x;
x4:=x2*x2;
x4:=5*x4;
y:=1-x2;
y:=y+x4;
y:=y*y;
writeln('y = ',y);
end.

Пример:
x = 2
y = 5929

Трассировка:
x=2
x2=2*2=4
x4=4*4=16
x4=5*16=80
y=1-4=-3
y=-3+80=77
y=77*77=5929
0,0(0 оценок)
Ответ:
kirya451
kirya451
03.10.2020 11:34
Var x,y:real;
begin
write('Введи x = ');readln(x);
y:=(1-x*x+5*x*x*x*x)*(1-x*x+5*x*x*x*x);
writeln('y = ',y);
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?