В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
maxim1213
maxim1213
08.11.2021 16:38 •  Информатика

Написать программу которая создает одномерный массив из n случайных эллементов (др1000) и выводит на экран 1. сам массив 2. кол-во нечет чисел 3. наим. эллемент массива 4 ср. ариф. членов массива

Ответ:
sdk2
sdk2
03.10.2020 11:32
Писал в среде PascalABC:

var a:array of integer;   
      k,min,s,n,i:integer;
begin
write('Задайте размер массива = ');readln(n);
writeln;
setlength(a,n);
for i:=0 to n -1 do begin
a[i]:=random(101);
if a[i] mod 2 <> 0 then k:=k+1;
if (a[i] < min) or (i=0) then min:=a[i];
s:=s+a[i];
end;
writeln('Массив:');
writeln(a);
writeln('Кол-во нечетных элементов = ',k);
writeln('Минимум = ',min);
writeln('Среднее ариф. = ',s/n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?