В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Marina20151111
Marina20151111
01.04.2022 15:13 •  Информатика

Составьте программу вычисления произведения последних четырех элементов одномерного массива a(n), заполнив его случайным образом

Ответ:
Раяна771155
Раяна771155
07.09.2020 18:57
Вариант №1

//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
begin
  var n:=ReadInteger('Размер массива: ');
  var a:=ArrRandom(n);
  a.Println;
  var p:=1;
  for var i:=n-4 to n-1 do begin
    p:=p*a[i];
  end;
  println(p);
end.

Тестовое решение:

Размер массива:  10
26 65 88 43 49 93 67 40 16 84
3601920

Вариант №2

const k = 100;
var a:array [1..k] of integer;
i,p,n:integer;
begin
  p:=1;
  readln(n);
  for i:=1 to n do begin
    a[i]:=random(21)-10;
    write(a[i]:4);
    if i>n-4 then p:=p*a[i];
  end;
  writeln;
  writeln(p);
end.

Тестовое решение:

10
  -8   6   1   3   1 -10  -3   2   2   2
-24
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?