В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Alexandra1031
Alexandra1031
16.01.2021 09:18 •  Информатика

С++ напишите программу, которая выводит номера элементов массива, равных заданному значению x . входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. в третьей строке записано число x . гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести в одной строке номера элементов массива, равных x , разделив их пробелами. предполагается, что нумерация начинается с единицы. если таких элементов нет, нужно вывести число -1.

Ответ:
D1999d3004
D1999d3004
03.10.2020 11:18
#include<iostream>#include<stdlib.h>using namespace std;int main(){ int n,i,j=0,k; cin>>n;  int a[n]; for(i=0;i<n;i++) { cin>>a[i]; } int X; cin>>X; int W[n]; for(i=0;i<n;i++) { if(a[i]==X) { W[j]=i; j++; }   } for(i=0;i<j;i++) cout<<W[i]<<" ";}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?