В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
AlexxxM1
AlexxxM1
16.10.2020 08:16 •  Информатика

программу: сельхозпредприятие реализует продукцию оптовым покупателям. существует базовая цена реализации на каждый вид продукции. в зависимости от количества реализуемой продукции покупателям могут предоставляться скидки: если вес продукции больше 100 кг, предоставляется скидка 5%, если вес больше 300 кг, скидка составляет 10% от базовой цены. составить программу определения стоимости реализуемой продукции, если известна базовая цена и количество продукции.

Ответ:
rzaevibragim
rzaevibragim
23.09.2020 19:36
Var price, k, s: real;
begin
write('Цена: ');
readln(price);
write('Количество: ');
readln(k);
s:=price*k;
if (k>100) and (k<=3001) then s:=s*0.95;
if k>300 then s:=s*0.9;
writeln('Итого:', s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?