В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
zalomnovavk
zalomnovavk
04.12.2021 01:07 •  Информатика

Имеется часть катушки с автобусными билетами. составить программу находящую номера счастливых билетов на катушке, если меньший номер билета на катушке - n, больший - m. номера билетов шестизначные, билет считается счастливым если сумма трех его первых цифр равна сумме трех последних.

Ответ:
ggggttttt
ggggttttt
19.08.2020 15:53
// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
begin
  var n:=ReadInteger('n=');
  var m:=ReadInteger('m=');
  var d1,d2,d3,d4,d5,d6:integer;
  for var i:=n to m do begin
    d6:=i div 100000;
    d5:=(i mod 100000) div 10000;
    d4:=(i mod 10000) div 1000;
    d3:=(i mod 1000) div 100;
    d2:=(i mod 100) div 10;
    d1:=i mod 10;
    if (d1+d2+d3)=(d4+d5+d6) then Write(d6,d5,d4,d3,d2,d1,' ')
    end
end.

Тестовое решение:
n= 163702
m= 164701
163703 163712 163721 163730 163802 163811 163820 163901 163910 164029 164038 164047 164056 164065 164074 164083 164092 164119 164128 164137 164146 164155 164164 164173 164182 164191 164209 164218 164227 164236 164245 164254 164263 164272 164281 164290 164308 164317 164326 164335 164344 164353 164362 164371 164380 164407 164416 164425 164434 164443 164452 164461 164470 164506 164515 164524 164533 164542 164551 164560 164605 164614 164623 164632 164641 164650
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?