В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составьте программу на языке паскаль. среди 15 случайных чисел из диапазона (-25; 15) найти количество чисел, делящихся на 5, но не делящихся на 10.

Ответ:
RstneaLeu
RstneaLeu
03.10.2020 11:06
Var a,k,i:integer;
begin
Randomize;
k:=0;
for i:=1 to 15 do
 begin
 a:=random(41)-25;
 write(a,'  ');
 if abs(a) mod 10 = 5 then k:=k+1;
 end;
writeln;
writeln('k = ',k);
end.

Пример:
-6  -20  -24  -22  10  -18  -10  10  -5  -12  9  -24  15  1  -15  
k = 3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?