В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
saaashaaa4656
saaashaaa4656
05.11.2021 14:16 •  Информатика

Составить программу вычисляющую сумму квадратов первых n натуральных чисел. количество чисел n задаётся во время работы программы. для разработки использовать приложение visual basic.

Ответ:
5Костя5
5Костя5
03.10.2020 11:03
1. Консольное приложение:

Module Module1

    Sub Main()
        Dim n, i, s As Integer
        Console.Write("Введите число N")
        n = Console.ReadLine
        s = 0
        For i = 1 To n
            s = s + i * i
        Next
        Console.Write(s)
        n = Val(Console.ReadLine)

    End Sub

End Module

2. Приложение Windows Forms:
На форме 3 объекта:
TextBox1 - для ввода N
Textbox2 - для вывода суммы квадратов
Button1 - чтобы запустить процесс вычислений

Public Class Form1

    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim i, s As Integer
        s = 0
        For i = 1 To Val(TextBox1.Text)
            s = s + i * i
        Next
        TextBox2.Text = s
    End Sub
End Class
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?