В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
SEreNAaaAA
SEreNAaaAA
12.11.2021 06:15 •  Информатика

Даны две дроби а/в и с/d (a,в,c,d — натуральные числа). составьте программу вычитания из первой дроби второй. ответ должен быть несократимой дробью. использовать подпрограмму алгоритма евклида для определения нод.

Ответ:
supermaxwtf
supermaxwtf
03.10.2020 11:00
// PascalABC.NET 3.1, сборка 1201 от 18.03.2016
function Euclid(a,b:integer):integer;
begin
  while a<>b do if a>b then a-=b else b-=a;
  Result:=a
end;

begin
  var a,b,c,d:integer;
  Write('Числитель и знаменатель первой дроби: ');
  Read(a,b);
  Write('Числитель и знаменатель второй дроби: ');
  Read(c,d);
  var zn:=b*d;
  var ch:=a*d-c*b;
  var sgn:=Sign(ch); ch:=Abs(ch);
  var gcd:=Euclid(ch,zn);
  Write('Результат вычитания: ');
  if sgn=-1 then Write('-');
  Writeln(ch div gcd,'/',zn div gcd)
end.

Тестовое решение:
Числитель и знаменатель первой дроби: 7 12
Числитель и знаменатель второй дроби: 3 4
Результат вычитания: -1/6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?