В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
anyutkavolf20
anyutkavolf20
08.04.2022 18:47 •  Информатика

Напишите программу в pascal, которая проверяет делимость введенного числа с клавиатуры на 2,3,4,5

Ответ:
tanyucsgha
tanyucsgha
07.08.2020 12:20
Var a:integer;
  flag:boolean;
begin
  flag:=false;
  write('Введите число ');
  readln(a);
  if a mod 2 = 0 then  begin
    writeln('Число ',a,' делится на 2');
    flag:=true;
  end;
  if a mod 3 = 0 then begin
    writeln('Число ',a,' делится на 3');
    flag:=true;
  end;
  if a mod 4 = 0 then  begin
    writeln('Число ',a,' делится на 4');
    flag:=true;
  end;
  if a mod 5 = 0 then  begin
    writeln('Число ',a,' делится на 5');
    flag:=true;
  end;
  if not flag then writeln('Число ',a,' не делится на 2,3,4,5');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?