В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ProgramAkkaunt
ProgramAkkaunt
19.03.2022 21:07 •  Информатика

Написать программу которая содержит подпрограмму-функцию которая вычисляет кол-во положительных элементов одномерного массива 10 компонентов вещественного типа. (решить на базе pascal 7.0)

Ответ:
nastyabelova01
nastyabelova01
15.09.2020 21:58
Const
  n = 10;

type
  ty = array[1..n] of real;

var
  ar: ty;
  i: integer;

function re(ar: ty): integer;
var
  i, k: integer;
begin
  k := 0;
  for i := 1 to n do
    if ar[i] > 0 then inc(k);
  re := k;
end;

begin
  for i := 1 to n do
    readln(ar[i]);
  writeln(re(ar));
end.

Пример ввода:
-1
0
1
1
1
1
1
1
1
-2
Пример вывода:
7
0,0(0 оценок)
Ответ:
Type tMas = array[1..10] of Real;
Var m : tMas;
  i : Byte;
Function OddFunc(b : tMas) : Byte;
Var j,n : Byte;
Begin
  n:=0;
  For j:=1 to 10 do If b[j]>0 then Inc(n);
  OddFunc:=n;
end;
Begin
  For i:=1 to 10 do
  Begin
    m[i]:=-100+Random(200);
    Write(m[i],' ');
  end;
  Writeln;
  Writeln(OddFunc(m));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?