Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Grizman7
18.09.2022 14:07 •
Информатика
Паскаль. дан массив. напечатать: 1) все элементы не превышающие число 100 2) все четные элементы 3) все элементы, являющиеся трехзначными числами 4) третий, шестой и т.д элементы. , все программы напишите полностью. не пишите по одной программе.
Ответ:
elenka421
23.09.2020 16:27
Const
n = 10;
var
a: array[0..10] of integer;
i, s: integer;
begin
//Заполнение массива сл. числами
for i := 1 to n do
begin
a[i] := random(201) - 100;
write(a[i]:4);
end;
writeln;
//1) Все элементы не превышающие число 100
writeln('Не больше 100 ');
for i := 1 to n do
if a[i] <= 100 then
write( a[i]:4);
writeln;
// 2) Все четные элементы
writeln('Кратные двум ');
for i := 1 to n do
if a[i] mod 2 = 0 then
write( a[i]:4);
writeln;
// 3) Все элементы, являющиеся трехзначными числами
writeln('Трехзначные ');
for i := 1 to n do
if (a[i] < -99) or (a[i] > 99) then
write(a[i]:4);
writeln;
// 4) Третий, шестой и т.д элементы.
i := 3;
writeln(' номера 3, 6, 9 и т.д.');
while i < n do
begin
write(a[i]:4);
i := i + 3;
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
mmmaaassshx
27.01.2023 07:08
Подскажите решение и как решать. По заданным ip-адресу и маске определите номер компьютера в сети: ip-адрес маска a)162.198.0.157 255.255.255.224 б)156.128.0.227...
zeus333
17.03.2023 02:47
1. Из двух восьми буквенных слов образовать строку, в которой чередуются буквы первого и второго слова. 2. Дан текст. Если в нем нет малых латинских букв, то оставить...
leg3
19.01.2021 19:38
Сколько чисел в ряде кодирования десятичного кода?...
enrnud6
22.03.2021 19:40
С ИНФОРМАТИКОЙ! ОТ ЗА ПРАВИЛЬНОЕ РЕШЕНИЕ. НУЖНО ВЫПОЛНИТЬ ДО СЕГОДНЯШНЕГО ДНЯ. Нажмите на картинку сверху, чтобы увидеть задачу...
Diana22855
11.03.2023 06:34
Что такое Сноки ,и где это применяется?ответьте...
RFHBYF456
10.05.2021 23:36
Используйте вместо модальных глаголов их эквиваленты. we may ask different questions....
1ирочка1
10.05.2021 23:36
Все стороны треугольника 3 см квадрата стороны все 4 см найди периметр этих фигур двумя...
Olgaekolesnik
10.05.2021 23:36
Чем вам интересна личность а. с. пушкина. заранее !...
Nasya156
10.05.2021 23:36
1) постройте фигуры, гомотетичные данной фигуре: 1) окружности 2) отрезку 3) треугольнику 4) четырехугольнику центр и коэффициент гомотетии выберите сами. 2) точки...
Gloriyaxx
10.05.2021 23:36
Как решить такой пример (-5/4-3/4) надо нужна ваша...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n = 10;
var
a: array[0..10] of integer;
i, s: integer;
begin
//Заполнение массива сл. числами
for i := 1 to n do
begin
a[i] := random(201) - 100;
write(a[i]:4);
end;
writeln;
//1) Все элементы не превышающие число 100
writeln('Не больше 100 ');
for i := 1 to n do
if a[i] <= 100 then
write( a[i]:4);
writeln;
// 2) Все четные элементы
writeln('Кратные двум ');
for i := 1 to n do
if a[i] mod 2 = 0 then
write( a[i]:4);
writeln;
// 3) Все элементы, являющиеся трехзначными числами
writeln('Трехзначные ');
for i := 1 to n do
if (a[i] < -99) or (a[i] > 99) then
write(a[i]:4);
writeln;
// 4) Третий, шестой и т.д элементы.
i := 3;
writeln(' номера 3, 6, 9 и т.д.');
while i < n do
begin
write(a[i]:4);
i := i + 3;
end;
end.