В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ERAZOR
ERAZOR
13.03.2021 05:38 •  Информатика

Написать программу на c++(целоцисленная арифметика). найти наибольшую и наименьшую цифры в записи заданного натурального числа.

Ответ:
Великолепныйум
Великолепныйум
23.09.2020 14:03
#include <iostream>
#include <iomanip>
using namespace std;

int main() {
   int i=0,n,mn=9,mx=0,k; 
   cout<<"n = ";  cin>>n;
   while (n!=0) 
   {
      k=n % 10;
     if (k>mx)  mx=k;
     if (k<mn)  mn=k;
     n=n/10;   
   }
   cout<<"max "<<mx<<endl;
   cout<<"min "<<mn<<endl<<endl;
   system("pause");
   return(0);
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?