В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
burcevyuriy
burcevyuriy
27.12.2020 02:41 •  Информатика

Pascal 1. дан прямоугольный треугольник с катетами a и b. составьте программу для вычисления гипотенузы c, периметра, площади, радиуса вписанной и описанной окружности. напишите программу в pascal

Ответ:
Zores
Zores
31.07.2020 17:56
Program calculations;
var a,b,c, S, P,poluperimetr , Radius1, radius2: real;

begin
writeln ('Enter a:');
readln(a);
writeln('Enter b:');
readln(b);
c:=sqrt(a*a+b*b);
S:=(a*b)/2;
P:=a+b+c;;
poluperimetr:=P/2;
Radius1:=c/2;
radius2:=sqrt(((poluperimetr-a)*(poluperimetr-b)*(poluperimetr-c))/poluperimetr);
writeln('c=',c:2:2);
writeln('S=',S:2:2);
writeln('P=',P:2:2);
writeln('Radius1=',Radius1:2:2);
writeln('radius2=',radius2:2:2);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?