Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
kseniatrof
26.10.2021 22:31 •
Информатика
Составьте блок-схему и опишите на языке программирования алгоритм вычисления площади круга. входные данные вводятся с клавиатуры
Ответ:
hhjjkh
07.09.2020 18:29
Да, конечно.
Итак, вот, что нужно добавить в блок-схеме(нарисовать не получится)
Итак, Овал(пустой), стрелочка вниз, паралеллограмм( пишешь r, S, Pi=3.14), Стрелочка вниз, прямоугольник (внутри S=Pi*r*r), стрелка вниз, параллелограмм(S), стрелочка вниз, пустой овал.
Вот программа:
Program KRUG;
var:r, S: real;
const Pi=3.14;
begin
writeln('Введите радиус круга');
read(r);
S:=Pi*sqr(r);
writeln('S=', S);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ievlevaaleksanra
01.03.2022 19:11
Z=cos^2(2пи*х) - 2 sin(пи*х) как правильно записать эту формулу в экселе...
leravolk399
14.08.2022 19:36
Ученик 8 класса читает текст со скоростью 250 символов в минуту. При записи текста использовался алфавит, содержащий 64 символа. Какой объем информации получит...
krissalis9
26.03.2023 05:33
Каков размер алфавита , используемого в компьютерах для представления текстов???...
Antoniow27
16.11.2022 03:09
на с++ сделать надо Дан файл целых чисел, содержащий четное количество элементов. Удалить из данного файла вторую половину элементов....
annakot3
18.08.2020 22:16
Написать программу, которая для введённой с клавиатуры строки (максимальная длина строки — 80 символов, использовать символьный массив) сообщает, какая цифра в...
maskaasenkova
01.05.2021 18:42
Почему после включения компьютера показывает редактор реестра, а после никуда (папки, пуск, скрыть и т.п.) нельзя нажать, хоть сама мышка двигается....
vorobeva85ramon
04.01.2021 16:19
Сколько символов содержит сообщение, записанное с символьного алфавита, если объем его составил 54 кибибайт?...
eshkeree1
03.07.2022 11:15
В чём разница между Canvas и SVG?...
teslinovpavel
19.01.2022 02:46
Рассматривается множество целых чисел, принадлежащих числовому отрезку[3672,9117], которые удовлетворяют следующим условиям): остаток от деления на 3 равен 2;остаток...
mehan2018
17.02.2022 07:48
Разложите на множители: а) 16-1/81х^4 б) 2х+х^2+2у-у^2...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Итак, вот, что нужно добавить в блок-схеме(нарисовать не получится)
Итак, Овал(пустой), стрелочка вниз, паралеллограмм( пишешь r, S, Pi=3.14), Стрелочка вниз, прямоугольник (внутри S=Pi*r*r), стрелка вниз, параллелограмм(S), стрелочка вниз, пустой овал.
Вот программа:
Program KRUG;
var:r, S: real;
const Pi=3.14;
begin
writeln('Введите радиус круга');
read(r);
S:=Pi*sqr(r);
writeln('S=', S);
end.