В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
KASPE72
KASPE72
25.01.2020 17:30 •  Информатика

Составить программу которая вычисляет произведение членов последовательности n натуральных чисел, кратных 5. программа получает на вход целые числа, количество введеных чисел неизвестно, последовательность заканчивается числом n.

Ответ:
Chakachoco
Chakachoco
03.10.2020 10:14
В условии задачи есть противоречие: с одной стороны количество чисел = N, а с другой - количество неизвестно, а дается признак конца последовательности. Программа дана для 2-го варианта.
var n,a:integer; p:real;
begin
write('n = '); readln(n);
write('a = '); readln(a);
p:=1;
while a<>n do
 begin
 if a mod 5 = 0 then p:=p*a;
 write('a = '); readln(a);
 end;
writeln('p = ',p);
end.

Пример:
n = 999
a = 6
a = 10
a = 24
a = 15
a = 56
a = 7
a = 5
a = 999
p = 750
0,0(0 оценок)
Ответ:
kosmagalaxy
kosmagalaxy
03.10.2020 10:14
Мой милорд, прибыли поставки в виде решения
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?