В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Camelia1980
Camelia1980
12.04.2020 07:25 •  Информатика

Нужно составить программу через процедуру в паскаль : каждая бактерия делится на две в течение одной минуты. в начальный момент имеется одна бактерия. составьте программу, которая рассчитывает количество бактерий на заданное вами целое значение момента времени. через procedure : (

Ответ:
homictana0
homictana0
23.09.2020 12:48
Procedure copy_bacterium(time:integer);
var
i, bacterium:integer;

    begin
    bacterium:= 1;
    for i:=1 to time do
        bacterium:= bacterium * 2;
    writeln(bacterium);
    end;
var
n:integer;
begin
readln(n);
copy_bacterium(n);
end.    
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?