В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
grantmarkaryan
grantmarkaryan
31.12.2021 11:57 •  Информатика

Дан массив из 12 элементов, в котором есть положительные и отрицательные числа (ноль тоже есть): а1=5, а2=4, а3=-3, а4=1, а5=0, а6=-4, а7=, а8=25, а9=-8, а10=-5, а11=-17, а12=-1. составьте программу, в которой 1 вариант: все отрицательные числа меняются на «1», все положительные на «-5», нулевые не трогаются. вывести на экран исходный и полученный массив.

Ответ:
Лизатян4
Лизатян4
15.09.2020 21:20
Const n=12;
a:array[1..n] of integer=(5,4,-3,1,0,-4,7,25,-8,-5,-17,-1);
var i:integer;
begin
for i:=1 to n do write(a[i]:4);
writeln;
for i:=1 to n do
 if a[i]<0 then a[i]:=1
           else if a[i]>0 then a[i]:=-5;
for i:=1 to n do write(a[i]:4);
end.

Результат:
5 4 -3 1 0 -4 7 25 -8 -5 -17 -1
-5 -5 1 -5 0 1 -5 -5 1 1 1 1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?