В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
11Misha201
11Misha201
13.01.2023 19:07 •  Информатика

Напишите программу на языке программирования (или составьте алгоритм). вычислить значение функции у = х^3+12 для х ϵ [–2, 2] при шаге изменения аргумента 0.2. выполнить программу и получить результат.

Ответ:
Kotazzz
Kotazzz
19.08.2020 15:17
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  var x:=-2.0;
  while x<=2 do begin
    Writeln('x=',x:4:1,' y=',x*x*x+12:6:3);
    x+=0.2
    end
end.

Результат выполнения программы:
x=-2.0 y= 4.000
x=-1.8 y= 6.168
x=-1.6 y= 7.904
x=-1.4 y= 9.256
x=-1.2 y=10.272
x=-1.0 y=11.000
x=-0.8 y=11.488
x=-0.6 y=11.784
x=-0.4 y=11.936
x=-0.2 y=11.992
x= 0.0 y=12.000
x= 0.2 y=12.008
x= 0.4 y=12.064
x= 0.6 y=12.216
x= 0.8 y=12.512
x= 1.0 y=13.000
x= 1.2 y=13.728
x= 1.4 y=14.744
x= 1.6 y=16.096
x= 1.8 y=17.832
x= 2.0 y=20.000
0,0(0 оценок)
Ответ:
AleksandrYamaha
AleksandrYamaha
19.08.2020 15:17
//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var x,y:real;
begin
  x:=-2;
  while x<2 do begin
    y:=x*x*x+12;
    writeln(' y = ', y);
    x:=x+0.2;
  end;
end.

Результат выполнения программы:
 y = 4
 y = 6.168
 y = 7.904
 y = 9.256
 y = 10.272
 y = 11
 y = 11.488
 y = 11.784
 y = 11.936
 y = 11.992
 y = 12
 y = 12.008
 y = 12.064
 y = 12.216
 y = 12.512
 y = 13
 y = 13.728
 y = 14.744
 y = 16.096
 y = 17.832
 y = 20
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?