В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
smoke228322
smoke228322
05.04.2023 01:06 •  Информатика

Составить программу которая находит количество двузначных чисел фибоначчи которые начиная с заданного номера n при делении на 5 в остатке заданное z

Ответ:
МсПолинэ
МсПолинэ
23.09.2020 10:59
Var a,b,c,n,n2,z:integer;
begin
 write('введите номер первого числа n ==> ');
 readln(n);
 write('введите искомый остаток ==> z ');
 readln(z);
 b:=0;
 n2:=0; 
a:=1;
  while c<100 do begin
    c:=a+b; 
    b:=a;
    a:=c;
    n2:=n2+1;
    if (n2>=n) and (c mod 5 = z) then writeln('нужное число ==> ',c);    
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?