В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Лера99100
Лера99100
15.10.2020 07:57 •  Информатика

Составьте программу перевода двоичной записи натуральных чисел в десятичную.(в pascal abc)

Ответ:
Nikita6537
Nikita6537
19.08.2020 15:13
Var i: integer;
    n,k: int64;
    s: string;
begin
  write('двоичное число:  ');  readln(s);
  k:=1;  n:=0;
  for i:=length(s) downto 1 do
  begin
    n:=n+(ord(s[i])-48)*k;
    k:=k*2;
  end;
  writeln('десятичное число:  ',n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?