В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Kuznecovanaste
Kuznecovanaste
23.09.2022 20:10 •  Информатика

Написать программу, которая в зависимости от введенного числа k, выполяняет разные действия. если число отрицательное или не делится на 4, то |k+5|, иначе k²+5.

Ответ:
александр383
александр383
23.09.2020 10:04
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
var k:integer;
begin
  writeln('Введите k ');
  readln(k);  
  if (k<0)or (k mod 4<>0) then writeln(abs(k+5))
    else writeln (sqr(k)+5);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?