В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Arion777
Arion777
08.03.2022 09:58 •  Информатика

Составить программу, решающую следующую : вы покупаете товар, и у вас имеются монеты номиналом 1, 2, 5, 10 рублей. наберите необходимую сумму товара в n рублей так, чтобы она состояла из минимального количества монет. язык паскаль

Ответ:
Fox1114
Fox1114
07.08.2020 11:31
Program noname;
var a,b,c,d,e;
begin
readln(a);
b:=a div 10;
a:=a-b;
c:=a div 5;
a:=a-c;
d:=a div 2;
a:=a-d;
e:=a;
writeln('Десяток:',b);
writeln('Пятёрок:',c);
writeln('Двоек:',d);
writeln('Единиц:',e);
writeln('Всего монет:'(b+c+d+e));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?