В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Х1ега1Х
Х1ега1Х
10.12.2020 20:39 •  Информатика

Напишите программу, которая позволит определить количество дней в течение заданного периода, в которые не было прибыли, и максимальную выручку за этот период. прибыль за день определяется как разность "выручка"-1000 (рублей) (если разность отрицательна, считать прибыль равной 0). на входе программа получает период n

Ответ:
mariaa987
mariaa987
27.05.2020 23:54

через генератор случайных чисел
program noname;
uses crt;
var
n,k,i:integer;
a:array[1..1000] of longint;
max:longint;
begin
clrscr;
write('vvedi period n=');
readln(n); k:=0;
for i:=1 to n do begin
randomize;
a[i]:=random(10000);
writeln(a[i]);
if a[i]-1000<0 then k:=k+1;
end;
max:=a[1];
for i:=2 to n do
if max<a[i] then max:=a[i];
writeln(k,'-дни без прибыли ',max,'-максимальная выручка');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?