В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Abbal
Abbal
25.08.2020 22:10 •  Информатика

Написать программу тест состоящую из пяти произвольных вопросов результат

Ответ:
кисуня208
кисуня208
31.07.2020 17:16
Program test;   var a:array [1..20] of string; b,c,d,e,f:string; i:byte;  begin  writeln('ответами в тесте будут являться номера ответов, а не сами ответы.');    writeln('Отмена крепостного права:');    a[1]:=('1. 1861 г.');    a[2]:=('2. 1886 г.');    a[3]:=('3. 1855 г.');    a[4]:=('4. 1889 г.');    for i:=1 to 4 do begin    writeln(a[i]);    end;    readln(b);    if b='1' then writeln('ответ верный') else writeln('ответ неверен');    //-------------------------------------------------------------------    writeln('Сколько будет корень третий степени из 8:');    a[5]:=('1. 8');    a[6]:=('2. 4');    a[7]:=('3. 1');    a[8]:=('4. 2');    for i:=5 to 8 do begin    writeln(a[i]);    end;    readln(c);    if c='4' then writeln('ответ верный') else writeln('ответ неверен');      //-------------------------------------------------------------------    writeln('Сколько слогов в слове рыбак:');    a[9]:=('1. 3');    a[10]:=('2. 4');    a[11]:=('3. 2');    a[12]:=('4. 1');    for i:=9 to 12 do begin    writeln(a[i]);    end;    readln(d);    if d='3' then writeln('ответ верный') else writeln('ответ неверен');     //-------------------------------------------------------------------      writeln('Столица Португалии:');    a[13]:=('1. Париж');    a[14]:=('2. Лондон');    a[15]:=('3. Лиссабон');    a[16]:=('4. Оренбург');    for i:=13 to 16 do begin    writeln(a[i]);    end;    readln(e);    if e='3' then writeln('ответ верный') else writeln('ответ неверен');    //-------------------------------------------------------------------      writeln('Как с английского переводится слово circuit:');    a[17]:=('1. Лампа');    a[18]:=('2. Колонка');    a[19]:=('3. Электрон');    a[20]:=('4. Схема');    for i:=17 to 20 do begin    writeln(a[i]);    end;    readln(f);    if f='4' then writeln('ответ верный') else writeln('ответ неверен');    end. 
У меня в паскале компилируется, всё работает. Если криво, ниже картинка
Написать программу тест состоящую из пяти произвольных вопросов результат
Написать программу тест состоящую из пяти произвольных вопросов результат
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?