В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
daskatyhg
daskatyhg
14.04.2023 15:23 •  Информатика

Написать программу,которая: 1. создает вещественный массив из 8 элементов; 2. заполняет массив элементами прогрессии с a0=1 и q=0.5; 3. подсчитывает количество элементов массива, меньших 0.1 4. присваивает симметрично значения первых 4 элементов массива значениям последних 4 элементов. после второго и четвертого действия вывести элементы массива в столбик.

Ответ:
merkulovaannet
merkulovaannet
31.07.2020 17:04
// PascalABC.NET 3.1, сборка 1184 от 02.03.2016
begin
  var a:=SeqGen(8,1.0,i->i*0.5).ToArray; // 1 и 2
  a.Println(NewLine); // вывод
  Writeln('Меньших 0.1: ',a.Count(x->x<0.1)); // 3
  for var i:=0 to 3 do Swap(a[i],a[7-i]); // 4
  a.Println(NewLine); // вывод
end.

Тестовое решение:
1
0.5
0.25
0.125
0.0625
0.03125
0.015625
0.0078125
Меньших 0.1: 4
0.0078125
0.015625
0.03125
0.0625
0.125
0.25
0.5
1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?