В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vlad2411
vlad2411
10.08.2022 10:41 •  Информатика

Составить программу на нахождение макимального значения в массиве чисел.

Ответ:
polinabaysha
polinabaysha
07.08.2020 20:53
Var
a:array[1..10] of real;
i,na:integer;
max:real;
begin
repeat
      writeln('Введите количество элементов массива меньше 11');
      readln(na);
until (na>0) and(na<=10);
writeln('Введите элементы массива,',na,' штук');
for i:=1 to na do
    begin
    readln(a[i]);
    if i=1 then max:=a[i]
    else
    if (a[i]>max) then max:=a[i];
    end;
writeln('Наибольший элемент массива = ',max);
end.
0,0(0 оценок)
Ответ:
maryrous
maryrous
07.08.2020 20:53
Сделано с рандомными числами.
program massiv;  var mas:array [1..10] of real; a:real; i:byte;    begin     a:=0;     for i:=1 to 10 do begin     mas[i]:=random(10)+1;      if a<mas[i] then a:=mas[i];     end;     writeln(a, ' - наибольшее из чисел массива ' );     end.     
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?