В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
galina1809
galina1809
31.01.2023 17:08 •  Информатика

Напишите программу которая в последовательности натуральных чисел находит среднее арифметическое трехзначных чисел или сообщает что таких чисел нет.

Ответ:
kravchenkomiss
kravchenkomiss
03.10.2020 09:05
// PascalABC.NET 3.1, сборка 1179 от 29.02.2016
begin
  var a:=ArrRandom(ReadInteger('n='),1,150);
  a.Println;
  var s:=a.Where(x->x in [100..999]);
  if s.Count>0 then Writeln('Ср.арифм. трехзначных ',a.Average)
  else Writeln('Нет трехзначных чисел')
end.

Тестовое решение:
n= 10
143 67 131 52 39 135 42 83 105 142
Ср.арифм. трехзначных 93.9
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?