В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
avf55
avf55
18.12.2020 13:59 •  Информатика

Написать программу которая формирует случайным образом массив из 20 целых чисел лежащих в диапазоне от 0 до 1000 после чего на экран выводится сам массив в одну строку следующей строке номер максимального элемента пробел максимальный элемент

Ответ:
1lёn1
1lёn1
03.10.2020 08:49
Так уже решал такую задачу:
const n=20;
var
  a:array[1..n] of integer;
  i,max,nmax:integer;
begin
  max:=0;
  for i:=1 to n do begin
    a[i]:=random(1001);
    if a[i] >max then begin
      nmax:=i;
      max:=a[i];
    end;
    write(a[i]:5);
  end;
  writeln;
  writeln(nmax,' ',a[nmax]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?