В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
arpinan
arpinan
03.02.2020 10:09 •  Информатика

Напишите программу в паскаль, которая получает день и номер месяца, а выводит количество дней, оставшихся до нового года. считайте, что год невисокосный (365 дней). учтите, что слово "дней" может иметь также формы "день" и "дня". пример: введите день и месяц: 25 12 осталось 7 дней до нового года. пример: введите день и месяц: 1 1 осталось 364 дня до нового года. пример: введите день и месяц: 31 2 неверная дата.

Ответ:
forsovae
forsovae
03.10.2020 08:43
//PascalABC
Uses System;
var day, month: integer;
begin
  Read(day, month);    var d := new DateTime(DateTime.Now.Year, month, day);    var new_year := new DateTime(d.Year+1, 1, 1);    Writeln((new_year - d).TotalDays);  end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?