В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Sergei12121
Sergei12121
28.02.2021 08:26 •  Информатика

Написать программу на паскале дана строка текста напечатать все слова,заканчивающиеся на "ов". если можно,то напишите программу с функции pos

Ответ:
TrinanenkoJulia
TrinanenkoJulia
03.10.2020 08:41
Считается, что слова отделяются друг от друга пробелом.
var s:string; p:integer;
begin
writeln('Введите строку:');
readln(s);
s:=s+' ';
p:=pos(' ',s);
while p>0 do
 begin
 if pos('ов ',s)=p-2 then writeln(copy(s,1,p-1));
 delete(s,1,p);
 p:=pos(' ',s);
 end;
end.

Пример:
Введите строку:
пример кров слово шов олово ров
кров
шов
ров
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?