В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
raviole1983oyfuky
raviole1983oyfuky
26.02.2020 22:54 •  Информатика

Напишите программу, которая вводит натуральное число n и определяет является ли число n совершенным. в паскале

Ответ:
katyar980
katyar980
03.10.2020 08:36
Совершенное число - натуральное число, равное сумме всех своих собственных делителей (то есть всех положительных делителей, отличных от самого числа).
 
//Pascal
var
  n, s, i: integer;

begin
  s := 0;
  readln(n);
  // Находим делители до n-1, увеличиваем сумму s на i,
  // если i - делитель введенного числа
  for i := 1 to n - 1 do
    if n mod i = 0 then s := s + i;
 
  if s = n then
    writeln('cовершенное')
  else   
    writeln('не совершенное');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?