В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
tatuxa223
tatuxa223
29.10.2020 21:12 •  Информатика

Напишите программу которая вычисляет сумму первых n натуральных чисел через оператор while

Ответ:
YarMax
YarMax
03.10.2020 08:30
Var
  n,c:integer;
Begin
  Write('Введите число ');
  Readln(n);
  Write('Сумма чисел от 1 до ',n,' равна ');
  While n<>0 do Begin
    c:=c+n;
    n:=n-1;
  End;
  Write(c);
End.
0,0(0 оценок)
Ответ:
ulyakiissaa
ulyakiissaa
03.10.2020 08:30
Var s,i,n:integer;

begin
  readln(n);

//цикл while
  s:=0;
  i:=0;
  while i<n do begin
     i:=i+1;
     s:=s+i;
  end;
writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?