В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Нетта771
Нетта771
28.03.2020 17:42 •  Информатика

Информатика, pascalabc, написать программу: вычислить площадь и периметр правильного n-угольника, описанного около окружности радиуса r (рассмотреть n-целого типа, r-вещественного типа)

Ответ:
ПтичкаСоловей
ПтичкаСоловей
03.10.2020 08:30
Var n:integer;
  s,p,r:real;

begin
  readln(n,r);
  p:=2*n*tan(Pi/n);
  s:=p*r/2;
  writeln( 'Периметр ', p);
  writeln( 'Площадь  ', s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?