Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
LOL8KEKYC
29.09.2020 08:43 •
Информатика
Составить программу для нахождения произведение чисел от 1 до n. для циклов: 1)for 2)while 3)until
Ответ:
moon137
22.09.2020 18:47
//Pascal
var
a, p: word;
i, n: integer;
begin
readln(n);
//цикл for
p := 1;
for i := 1 to n do
p := p * i;
writeln(p);
//цикл while
i := 1;
p := 1;
while i <= n do
begin
p := p * i;
i := i + 1;
end;
writeln(p);
//цикл repeat
i := 1;
p := 1;
repeat
p := p * i;
i := i + 1;
until i > n;
writeln(p);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
hychkairyna
12.03.2023 19:01
Посситай сколько байт информации содержит 88 бит...
vadimkaIVA
12.03.2023 19:01
По информатике. информационный объем сообщения 35 кб. известно, что данное сообщение содержит 71680 символов. какова мощность алфавита? решить ....
Маринрчка
12.03.2023 19:01
Посчитай сколько байт информации 40 кб...
nanaminer
12.03.2023 19:01
1. дан целочисленный массив с количеством элементов n. образовать новый массив из элементов исходного массива , принадлежащих интервалу [a; b]. 2.дан целочисленный массив (1,1,1,0,0,0,1,1,1,0,0,...
stru4kovav13
12.03.2023 19:01
Найдите все простые числа на отрезке [a,b] их сумму и произведение (составить программу в pascal)...
dobryninatonya
22.06.2022 20:15
# В тексте буква h встречаеться как минимум 2 раза. # Программа должна удалить все символы от первого вхождения # буквы h до последнего вхождения буквы h и записать это в новую...
КсюшаАнтропова
22.07.2020 20:54
Какие два значения имеет слово бит?...
ДашуляСупер
25.12.2020 21:09
Для изображение используется 256 цветов разрешающея экрана 640*480.какой обьем видео памяти необходим для хранения изоброжения...
гребок
15.05.2023 00:05
Pascal. , , исправить ошибку. оптимизировать код и т.п. не мне только надо заставить этот код работать правильно, все остальное я уже сделаю сама. сама программа должна по...
tven1808
15.05.2023 00:05
Как потому что происходит в моей местноти можно определить что земля имеет форму шара...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
a, p: word;
i, n: integer;
begin
readln(n);
//цикл for
p := 1;
for i := 1 to n do
p := p * i;
writeln(p);
//цикл while
i := 1;
p := 1;
while i <= n do
begin
p := p * i;
i := i + 1;
end;
writeln(p);
//цикл repeat
i := 1;
p := 1;
repeat
p := p * i;
i := i + 1;
until i > n;
writeln(p);
end.