В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Dyakgod
Dyakgod
27.02.2020 23:22 •  Информатика

Составить программу паскаль для нахождения площади трапеции с основаниями а ,б меньшн h

Ответ:
yusdanila
yusdanila
07.08.2020 10:21
{ s(трапеции) = ((a+b)/2)*h; }
uses crt;
var
a, b, h: Integer; (Real)
s: Real;
begin
WriteLn('Введите а: ',a);ReadLn(a);
WriteLn('Введите b: ',b);ReadLn(b);
WriteLn('Введите h: ',h);ReadLn(h);
s:= ((a+b)/2)*h;
WriteLn('S = ', s);
ReadLn;
end.
Если же а и б должны быть обязательно меньше h, то:
if (a < h) and (b < h) then
begin
WriteLn('Введите а: ',a);ReadLn(a);
WriteLn('Введите b: ',b);ReadLn(b);
WriteLn('Введите h: ',h);ReadLn(h);
s:= ((a+b)/2)*h;
WriteLn('S = ', s);
ReadLn;
end;
else begin
WriteLn('Основания не меньше h!');
ReadLn;
end;
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?