В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Gaky
Gaky
23.01.2022 00:44 •  Информатика

Составить программу которая определяет количество чисел в интервале от 100 до 1000 одновременно делящихся на 5 и 21

Ответ:
Вано137
Вано137
03.10.2020 08:21
Пример, когда лучше сначала подумать, а потом писать программу.
Если число делится одновременно на 5 и 21, то оно делится и на их произведение, т.е. на 105.
Количество таких чисел на указанном интервале может быть найдено как
\displaystyle k=\left \lfloor{ \frac{1000-105}{105}}\right\rfloor+1=9
Здесь "скобки" означают операцию взятия целой части.
Т.е. ответ уже получен, но раз требуется программа, то можно её написать так:

// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
  Writeln((1000-105) div 105 + 1)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?