В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
svetburtseva20
svetburtseva20
01.04.2022 00:34 •  Информатика

Составить программу определяющую можно ли построить прямоугольник по четырем заданным отрезкам

Ответ:
renatamamarenata
renatamamarenata
25.08.2020 10:57
// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
  var a:=ReadArrInteger('Введите стороны',4).Sorted.ToArray;
  if (a[0]=a[1]) and (a[2]=a[3])
  then Writeln('Можно построить прямоугольник')
  else Writeln('Нельзя построить прямоугольник')
end.

Тестовые решения:
Введите стороны 6 12 12 6
Можно построить прямоугольник

Введите стороны 6 12 12 7
Нельзя построить прямоугольник
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?