В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Проник755
Проник755
29.01.2023 12:39 •  Информатика

Дано некоторое число составьте программу которая выводит какое это число положительное или отрицательное если оно положительное уменьшить в 2 раза а в другом случае взвести в квадрат.

Ответ:
ybibisheva
ybibisheva
03.10.2020 08:06
//Pascal ABC.NET v3.1 сборка 1172

Var
 a:real;
begin
 readln(a);
 if a>0 then writeln('Положительное, ',a/2) else
  if a<0 then writeln('Отрицательное, ',sqr(a)) else
   writeln('0');
end.

Пример ввода:
-12
Пример вывода:
-, 144
0,0(0 оценок)
Ответ:
Anna66613
Anna66613
03.10.2020 08:06
По моему такая задача уже несколько раз была здесь.
//Pascal
var a:integer;
begin
  readln(a);
  if a>0 then writeln('Положительное ', a/2)
     else
         if a<0 then writeln('Отрицательное', a*a);
  if a=0 then writeln('0 - не положительное и не отрицательное число');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?