В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lurudzheva
lurudzheva
17.08.2020 13:16 •  Информатика

Составить программу в паскале: дан одномерный массив найдите разность наибольшего и наименьшего элемента этого массива

Ответ:
vlad67123222
vlad67123222
25.08.2020 10:47
Var 
a:array[1..10] of integer; 
max,min,i:integer;
Begin 
for i:= 1 to 10 do Begin   
write('Введите ',i,'-ый элемент массива ');   
Readln(a[i]);   
if i=1 then Begin     
min:=a[i];     
max:=a[i];   
End;   
if a[i]>max then max:=a[i];   
if a[i]<min then min:=a[i]; 
End; 
Write('Разность наибольшего и наименьшего равна ',max-min);
End.  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?