В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составьте программу, позволяющую проверить, можно ли из букв слова х составить слово у. буквы можно переставлять, но каждую букву можно использовать только 1 раз.

Ответ:
sofia060506
sofia060506
07.09.2020 16:26
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
  var x:=ReadlnString('Введите слово Х:');
  var y:=ReadlnString('Введите слово Y:');
  var Good:=True;
  for var i:=1 to y.Length do begin
    var p:=Pos(y[i],x);
    if p>0 then Delete(x,p,1)
    else begin Good:=False; Break end
    end;
  if Good then
    Writeln('Можно составить ',y)
  else
    Writeln('Нельзя составить ',y)
end.

Тестовое решение:
Введите слово Х: образование
Введите слово Y: название
Нельзя составить название

Введите слово Х: образование
Введите слово Y: барон
Можно составить барон
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?