В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Цири
Цири
01.05.2021 07:58 •  Информатика

На паскале написать программу сокращения дроби , где n – целое, m – натуральное число. использовать алгоритм евклида. разработать тесты для проверки правильности работы программы.

Ответ:
MAN1337228
MAN1337228
22.09.2020 12:08
Program ex2;
uses crt;
var a, b, x: real;
begin clrsc;
write('a='); readln(a);
write('b='); readln(b);
{алг. Евклина для НОД}
end.
0,0(0 оценок)
Ответ:
artik12042003
artik12042003
22.09.2020 12:08
Var
 n,m:integer;
 a,b:integer;
begin
 read(n,m);
 a := abs(n);
 b := m;
 while a <> b do
   if a > b then
     a := a - b
   else
     b := b - a;
 b := m div a;
 a := n div a;
 writeln(a,'/',b);
 if a*m = b*n then writeln('Correct')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?